Welcome, Guest. Please Login or Register
MyECU main site
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
Pages: 1 2 
Send Topic Print
app android (Read 1030 times)
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
app android
10/21/23 at 20:11:32
 
i have a problem with the app for android. i can upload and download the map ,
I assume that the connected bleutooth works.
but it doesn’t show the battery voltage and the rev counter.
works for 2 years
Back to top
 
 
IP Logged
 
YaBB Administrator
YaBB Administrator
*****
Offline


I love YaBB!

Posts: 677
The Land of YaBB
Re: app android
Reply #1 - 10/22/23 at 09:33:16
 
Please email me the log file the app is producing.
Back to top
 

The Administrator.
WWW  
IP Logged
 
sign216
Full Member
***
Offline



Posts: 176
Re: app android
Reply #2 - 10/22/23 at 11:02:55
 
alessandro ferrari wrote on 10/21/23 at 20:11:32:
i have a problem with the app for android. i can upload and download the map ,
I assume that the connected bleutooth works.
but it doesn’t show the battery voltage and the rev counter.
works for 2 years


Just today I tried to use the app, and found it wasn't connecting.  In the past it was finicky too.  I'll try again, after I review my prior notes.
Joe
Back to top
 
 
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #3 - 10/24/23 at 02:23:01
 
hi, i will send you tomorrow , thanks .
Back to top
 
 
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #4 - 10/24/23 at 20:57:45
 
hi , this the log
Back to top
 
 
IP Logged
 
YaBB Administrator
YaBB Administrator
*****
Offline


I love YaBB!

Posts: 677
The Land of YaBB
Re: app android
Reply #5 - 10/25/23 at 07:35:01
 
Well there is no two way communication happening so even your map upload is not working.
It is possible that you are connected to something other than the ECU.
Start the app with the bike off and then do the scan again after turning the bike on.
Back to top
 

The Administrator.
WWW  
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #6 - 10/25/23 at 18:01:13
 
thanks Jefferies, i'll do this morning
Back to top
 
 
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #7 - 10/25/23 at 21:17:06
 
hi, i have tried two times today ,have to different logs..
im checking the dongles cable
the  third file is exported after reassembly the dongle. i habe try to get map and load a new map
Back to top
« Last Edit: 10/25/23 at 21:57:02 by alessandro ferrari »  
 
IP Logged
 
YaBB Administrator
YaBB Administrator
*****
Offline


I love YaBB!

Posts: 677
The Land of YaBB
Re: app android
Reply #8 - 10/26/23 at 06:29:10
 
I noticed you are using the latest app. Where you on a previous version? Did this problem start after the upgrade?
That last file is showing noise being received that wasn't in the previous logs.
12:46:54- ��������������������������������������������������������������������������������
��������������������������������������������������������������������������������
��������������������������������������������������������������������������������
����������������
12:46:59-
Back to top
 

The Administrator.
WWW  
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #9 - 10/27/23 at 03:51:56
 
i have tryed olds version 1.05b 1.06e 1,07a.
all version crash when try to load the map.
install the last app .
modified this line
RPM         500 1500  2000  2500  3000  3600  3800  4000  4400  4800  5000  5400  5600  6800  7600  8143
to
RPM         1000  1500  2000  2500  3000  3600  3800  4000  4400  4800  5000  5400  5600  6800  7600  8143

in attach the last log. seems to be ok , no more
��������������������������������������������������������������������������������

��������������������������������������������������������������������������������

��������������������������������������������������������������������������������

����������������
but this message is weird (for me)
OptimiserActivity - Failed to set map entry 00
you have wrote this map didnt work. is a ecu problem , map wrong or something else?

thank for your time  Smiley
Back to top
 
 
IP Logged
 
YaBB Administrator
YaBB Administrator
*****
Offline


I love YaBB!

Posts: 677
The Land of YaBB
Re: app android
Reply #10 - 10/27/23 at 07:25:05
 
"Failed to set map entry 00" is what I would expect if it was not talking to the ECU properly. The app has sent the command but not received a response from the ECU.
I think you should check the dongle in isolation. Apply the 5V and ground and connect the RX to TX and then connect with the app.
Back to top
 

The Administrator.
WWW  
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #11 - 10/28/23 at 02:56:12
 
hi Cliff,
I did yesterday, redo the solder in the dongle. The strange marks are gone. but that error remains. a proof that I had never done and been to match it only with the bluetooth of the phone, without opening the app. It gives me the error that the ecu does not give permission. Is it correct?.
maybe i need to buy a new dongle.
is possible have the circuit diagram of ecu? for checking the components. or the first check list after assembly is a good trouble shooting .
Back to top
 
 
IP Logged
 
YaBB Administrator
YaBB Administrator
*****
Offline


I love YaBB!

Posts: 677
The Land of YaBB
Re: app android
Reply #12 - 10/28/23 at 07:48:05
 
Go to the android app settings and explicitly turn permissions on there. Please also try the loop back test on the dongle as I suggested with the dongle isolation test and send another log.
Back to top
 

The Administrator.
WWW  
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #13 - 10/30/23 at 01:56:17
 
good afternoon ,
anroid app have all permission, in attache the log with loop back test.
Back to top
 
 
IP Logged
 
alessandro ferrari
YaBB Newbies
*
Offline


I love MyECU!

Posts: 16
Rome
Gender: male
Re: app android
Reply #14 - 11/05/23 at 01:02:49
 
hi, i made any mistake? when you asked me  "loop back test on the dongle"
i have connected the dongle with external 5 volt power supply. connected the the rx and tx together . is correct?
Back to top
 
 
IP Logged
 
Pages: 1 2 
Send Topic Print